Rubrik Security Cloud Gov experiencing degraded availability

Incident Report for Rubrik Gov

Resolved

This incident has been resolved.
Posted Jun 12, 2025 - 15:39 PDT

Monitoring

Rubrik Security Cloud Gov services are recovering. We are actively monitoring the status updates from Google Cloud.
Posted Jun 12, 2025 - 13:59 PDT

Identified

Our upstream provider, Google Cloud, is experiencing an issue which might impact multiple products within Rubrik Security Cloud Gov
Posted Jun 12, 2025 - 12:16 PDT

Investigating

We have noticed degraded availability for Rubrik Security Cloud Gov. We are currently investigating the issue.

Symptoms: We are still investigating the scope of the issue.

Incident Start Time: 06/12/2025 10:59 AM PDT

Workaround: None at this time.

Our engineering team is actively investigating to resolve this issue.
Posted Jun 12, 2025 - 11:52 PDT
This incident affected: US-Gov-1 (Rubrik Security Cloud - Data Protection, Data Security Posture, Ransomware Monitoring and Investigation, Microsoft 365 Protection, Cloud Data Protection).